Symptom
Some customers opts to use some third-party integrations to perform the External to Internal conversion and the job fails due to the difference between SF timezone and the timezone which the integration is set.
Environment
SAP SuccessFactors Recruiting Management - All Versions
Cause
If it's around midnight to the SF system time, for example, between 11:00 PM and 1:00 AM of the next day, and the integration is executed on this period, there is a change internal profile gets created and the candidate gets placed in the hired status only the next day, therefore the conversion will fail. It's known that the external to internal candidate conversion will occur if the internal user profile is created on the same day or after, the external candidate is placed in hired status. More information about the job in the KBA 2249476 - External to Internal Candidate Profile conversion - Recruiting Management.
Resolution
There is an ongoing internal request where this scenario will be analyzed by Software Engineering team.
As best practice, the integration should be set up based on the SF timezone and also, not near by midnight, so this discrepancy can be avoided. In case you already have some affected candidates, you can merge both external and internal profiles manually through the Manage Duplicate Candidates - 2103863 - Manage Duplicate Candidates - Recruiting Management.
See Also
2103863 - Manage Duplicate Candidates - Recruiting Management
2249476 - External to Internal Candidate Profile conversion - Recruiting Management
Keywords
External to Internal Conversion, Ext to Int, Timezone, Failed, Fail, , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem