SAP Knowledge Base Article - Public

2898404 - The Candidate Email Permission feature is not working

Symptom

You have setup the Candidate Email Permission feature to limit the operators who can email applicants, as shown here.

However, non-permissioned operators still have permission to email the candidates using the "Contact Candidate" button on the application.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Setup the Candidate Email Permission feature on the Job Requisition Template
  2. Access an application as an operator that has not been given permission to contact applicants
  3. Notice that they can still contact the applicant

Cause

If SMS feature is enabled in Manage Recruiting Settings, then the "Contact Candidate" button will be visible, even if the Candidate Email Permission feature is configured.

This is because both emails and SMS use the "Contact Candidate" button, and so it must show for all operators when SMS is enabled.

Resolution

This is expected behaviour. If you would like to see this behaviour changed, please consider creating an enhancement request for the system to our Product Management Team, as described in KBA 2090228 - "How to Submit Enhancement Requests for SAP SuccessFactors Products"

See Also

KBA 2090228 - "How to Submit Enhancement Requests for SAP SuccessFactors Products".

Keywords

SMS, short message service, email, permission, portlet,  , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions