Symptom
You have performed changes in the items of the Inbound Delivery and expected to see these changes in the Customer Return.
Environment
SAP Business ByDesign
Reproducing the Issue
In this example we will use the following example:
- ABC represents the ID of the Customer Return.
- GHI represents the ID of the Warehouse Order.
- MNO represents the ID of the Customer Invoice.
- XYZ represents the ID of the Inbound Delivery.
- Go to the Sales Orders work center.
- Select the Returns view.
- Search for Customer Return ABC.
- Click Edit.
You see that item 10 was mistakenly released with 0 quantity, thus creating a Credit Memo with 0 quantity and not with a quantity of 1 as expected.
- Go to the Document Flow tab of the Customer Return.
- Open the Inbound Delivery XYZ.
- Click Undo Release.
- Navigate to the Document Flow tab.
- Open the Warehouse Order GHI.
- Click View All button.
- Click on Adjustment Confirmation button.
- Select line 10 and click Enable Entry.
- Change the Quantity Difference to 1.
- Click Save.
- Go to the Inbound Delivery XYZ and click Release.
- Go to the Returns view.
- Search for the ID ABC.
- Click Edit.
- Navigate the Items tab.
The quantity added to the item under the Inbound Delivery XYZ did not update to the Customer Return ABC.
Cause
Once the Customer Return has been released With Credit Memo, the system does not perform updates from changes made in the Inbound Delivery to the Customer Return.
Updated information from the Inbound Delivery to the Customer Return will only happen when the Return has not been released.
Resolution
This is expected system behavior.
To correct this, please perform the following steps.
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Select the Invoice MNO.
- Click Cancel.
- Save the new canceled Invoice.
- Go to the Inbound Logistics work center.
- Select the Inbound Deliveries view.
- Search for ID XYZ.
- Click Undo Release.
- Go to the By Warehouse Order view.
- Search for the ID GHI.
- Click Edit.
- Click on Adjustment Confirmation button.
- Select line 10 and click Enable Entry.
- Since you had already added the expected number previously, now perform the following.
- Make the quantity negative, such as -1.
- Click Save.
- Change the quantity to 1 (positive).
- Click Save.
- Go back to the Inbound Deliveries view.
- Search for ID XYZ.
- Click Release.
- Go to the Sales Orders work center.
- Select the Returns view.
- Search for Customer Return ABC.
- Now the document's status has changed from Completed to In Process.
- Click Edit.
- Navigate to the Items tab.
- Credited Quantity is now enabled.
- Change the value to 1, making it equal to Planned Quantity.
- Click Release and select With Credit Memo.
- Go to the Customer Invoice work center.
- Select the Invoice Requests view.
- Search with the ID ABC (reference to the Customer Return).
Document is with the To Be Invoiced status with the expected quantity.
See Also
2216315 - The Customer Return Invoice Request is Having the Net Value as Zero
Keywords
Customer Return, Update, Inbound Delivery, Item, Quantity, Customer Return Invoice Request, Quantity, Zero , KBA , AP-CRP-CR , Customer Return , How To