Symptom
You have scoped the question related to survey versioning in the business configuration, yet the functionality is not active.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Click Edit Project Scope.
- Navigate to the Questions tab.
- Expand the element Sales
- Go to subelement Account and Activity Management.
- Select Activity Management.
- Make sure the Question 'Do you want to enable versioning in Survey?' is checked and reviewed.
- Click Next and Finish the scoping changes.
- Go to the Surveys work center.
- Go to the Surveys view.
- Open Survey 123 (where 123 is Survey ID) whose status is In Preparation.
- Click the Actions button
You will see that the option Create New Version is not available.
Cause
You have not activated the change project in which the relevant change is made.
Resolution
1. Go to Business Configuration Work Center
2. Go to Implementation Projects view
3. Select the relevant project where this scoping is activated
4. Select Open Activity List
4. Open the activity named Activate Solution Capabilities
5. Select Confirm button
This activity is necessary to ensure that all scoping changes made in a change project become fully effective.
Can you perform the next steps even though Test and Production are not in the same version?
If the change project is already merged, the activation can be performed immediately. For this step, it is not necessary to have matching versions in production and test tenant. However, if the change project is not yet merged, then it first needs to be merged before the activation, and the merge can only be performed provided the system versions match, i.e. after the productive upgrade.
See Also
KBA 2651946 - Create New Version In Survey
Keywords
Survey, Version, Active, Create New Version, Scoping , KBA , survey , version , question , business configuration , LOD-LE-SUR-DEF , Survey definition = design time , How To