Symptom
You are using the data source Installation Point (CRMIPOINTHB) and you notice that the field Registered Product shows # (unassigned) in some cases.
Environment
Cloud for Customer
Reproducing the Issue
- Go to the work center Business Analytics and the view Design Data Sources.
- Search for Installation Point.
- Click Preview.
- Make the required selections by adding an Installation Point ID.
- Add the field Registered Product to the view.
- It shows # (unassigned).
Cause
The Data Source CRMIPOINTHB is used to show data for both Ipoints and Registered Products (which is also a type of IPoint). The Registered Product field shows the serial ID and description of that registered product. Note that it shows the registered product of the same id and not of the sub items.
Hence if you filter for a specific installation point which is not a registered product, the field shows #.
If you select an ID of a registered product, then the field Registered Product shows the serial ID and description of that registered product.
Resolution
If you would like to view sub items of an installation Point, then you can make use of the variable Parent Installation Point ID in the selection.
Keywords
installation point, registered product, CRMIPOINTHB, missing data, #, reporting, business analytics, data source, datasource, ipoint, parent , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To