SAP Knowledge Base Article - Public

2899432 - Field Value is not set to Null by OnChange Business Rule When Performing an Internal Hire in MPH

Symptom

When hiring an Internal Hire, if an onChange business rule is configured to set a field to null, the field is not changed and the old data remains

Environment

Employee Central - Position Management

Reproducing the Issue

  • Configure a business rule to set a field to null and set it onChange on the position field
  • Navigate to Manage Pending Hire > Internal Hire > Hire
  • Notice that the field in question is not changed to null
  • The data that was there before remains
  • A rule trace shows that the data was changed to null, despite no changes occurring

Cause

This is a functional gap in the system, engineering have raised an enhancement request for this issue but have no fix has been issued yet.

This KBA will be updated once engineering commit to a concrete date for a fix

Resolution

As a workaround, re-selecting the position will cause the onChange rule to trigger once more, which correctly updates the data

Keywords

Manage Pending Hire, MPH, Internal Hire, business rules, onChange, Position, null, ECT-118098 , KBA , LOD-SF-EC-POS , Position Management , Problem

Product

SAP SuccessFactors Employee Central all versions