SAP Knowledge Base Article - Public

2899561 - Email notification settings reset after each login - Jam Collaboration

Symptom

Users change their Jam email notification settings, but once they log-out and sign-in again, the settings saved previously are gone.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

Jam Collaboration

Cause

Jam has the logic if the email domain matches the generated "cubetree.biz", each time updating the member like logout/login, we will set all the email notification settings to false. The reason for this is that Jam threat this generated domain "cubetree.biz" as not a valid email address. 

Resolution

Please make sure that:

  1. Email field is populated on HCM Suite (BizX) side
  2. Jam is not restricting the email from HCM Suite to be updated on Jam side

In case you are sure that the email field is populated correctly on HCM Suite side, please check if Jam is not restricting the Email field from being populate as per screenshot below:

See Also

2776993 - Email Notifications are not being received

Keywords

jam email settings reset, email settings reset, jam settings reset, jam notification settings , KBA , LOD-SF-JAM-EML , Email Notification Issues , How To

Product

SAP Jam Collaboration 1905