Symptom
You are executing an addressability check in a target group and receive the below errors.
Errors:
Addressing members by channel E-Mail is not possible.
You can't contact members. It's not permitted.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Campaign workcenter
- Go to Target Group view
- Select Show all and open XYZ (XYZ represents the name of the target group)
- Navigate to Members facet
- Select More
- Select Check E-Mail Address
You will see the afore mentioned errors.
Cause
You have restricted the permissions in the contact or Account
Resolution
In order for the mail to sent, permissions should be allowed in the contact/Account, you can check for the same by following the steps below
- Go to Customers workcenter
- Go to Account/Contacts view
- Select Show all and find for ABC (ABC represents name of the Account/contact)
- In the header of the account/contact, check if field Contact Permission is set to Allowed
- Go to Marketing Permission facet in Contact
- In the Marketing Permission section, check if the consent is set to Opt-In against the Channel E-Mail
If the Contact Permission in the header of contact is set to Disallowed, then system will not consider the marketing permissions.
If the Contact Permission in the header of contact is set to Check Permission, then system will check for the marketing permission and see if consent is set to Opt-In against the Channel E-Mail
See Also
Keywords
E-Mail Addressability, Target Groups, Sales Campaigns, Members, Mail, Marketing Permissions , KBA , e-mail addressability , marketing permissions , target groups , sales campaigns , you can't contact members , it's not permitted. , LOD-CRM-MKT-TG , Target Groups , LOD-CRM-MKT , Marketing , Known Error