Symptom
In Managed Dispute Cases Fiori, user is trying to add an attachment as a PDF file but
received the following error:
Error during communication with the SAP system: MIME type application/pdf for file & not allowed for the upload
Environment
- SAP S/4HANA, cloud
Reproducing the Issue
- Go to Fiori application 'Process Receivables'
- Enter customer number and click the 'Go' button
- Click on the > button
- Click on 'Disputes'
- Click on the Case id number
- Scroll down and click on 'add attachments'
- Upload PDF file
- Saved changes
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
Missing configuration in table/view V_UDMFILEEXT2
Resolution
- Transaction SPRO
- Financial Supply Chain Management
- Dispute Management
- Dispute Case Processing
- Enterprise Services
- Define Document Category for Attachments to Dispute Cases
- Maintain document class (i.e. PDF - MIME type: application/pdf)
See Also
Review table SDOKMIME for MIME type list in SE16 transaction
Keywords
Application/pdf, Dispute, Dispute management, Process receivables, UDM_MSG169, SDOKMIME, Attachment, V_UDMFILEEXT2, Dispute cases , KBA , PLM-FIO-DMS , Fiori UI for Document management , FIN-FIO-CCD , Fiori-UI for SAP Collections Management, SAP Credit Managem. , Problem