Symptom
You would like to understand how the phone number search works in CTI Live Activity when receiving an inbound call from a customer.
Environment
SAP Cloud for Customer
Reproducing the Issue
[Enter your Reproducing the Issue here...]
Cause
[Enter your Cause here...]
Resolution
Below are some ways the phone number can be sent in the Inbound Call:
- XXX XXX XXXX
- XXX-XXX-XXXX
- XXXXXXXXXX
The Cloud for Customer standard behavior is to treat the number in the search field as it would treat any other text like “Test”, “Jimmy” etc. Therefore a phone number with hyphens and without hyphens are two separate text searches as far as Enterprise Search is concerned and depending on the data in the system, you will get the corresponding results.
The space between the numbers retrieve the number with hyphens as it is the "text" which approaches the most of the original way the data is maintained in the system.
Keywords
Phone; Phone Number; CTI; Live Activity; Call; Inbound Call; Service; Format; XXX XXX XXXX; XXX-XXX-XXXX; XXXXXXXXXX; , KBA , LOD-CRM-SRP , Service Request Processing , How To