Symptom
You have a workflow rule which condition uses the Matches Pattern operator, comparing a description field with a text value, however you notice that the workflow rule does not trigger when the text condition is met.
Environment
SAP Cloud for Customer
Cause
When using a condition with the Matches Patter operator, comparing with a description field with a text value, it is required to add the value using an asterisk * in the workflow rule configuration.
Resolution
Once you add the asterisk * in the text value condition, the workflow rule will trigger as expected in the system.
The asterisk can be added like the following examples:
- *TEXT or TEXT* - will compare the condition with any word that contains the word TEXT + anything else along with it, before or after it.
- *TEXT* - will compare the condition with any word that contains anything else before and anything else after the specific word TEXT in the middle.
Keywords
Workflow Rule; Description; Matches Pattern; Description; Condition; Does not Trigger; Not Working; C4C; Service; Ticket; , KBA , LOD-CRM-WKF , Workflow , How To