SAP Knowledge Base Article - Public

2901193 - Auth. Error related to Invalid Manager ID is getting returned while executing ODATA API Calls

Symptom

You are getting below mentioned error when a specific user is executing ODATA API query:

[LGN0019]Authentication failed. You have provided an invalid manager ID (status code = 18)

Environment

SAP SuccessFactors HXM Suite ODATA API

Reproducing the Issue

  1.  Run SAP SuccessFactors ODATA API Query with the impacted API User via any REST Client or SAP Middle-ware.
  2.  Or Try to login to the respective SFSF System with the impacted API User.

Cause

The reason behind this issue is, the user that is trying to login (via API or UI) is assigned to a manager that is not active in the system (manager status is inactive).

Resolution

  1. Assign an active manager to that user;
    OR
  2. Update the current manager status to active.
    OR
  3. Set the users manager to NO_MANAGER. This can be used for example the CEO of your company who will not have a manager or if there is a temporary change of manager needed.

 

NOTE: This assignment and update can be done via "Admin Center > Manage Users" (for non-EC instances) or "Admin Center > Employee Export & Import" (for EC instances).

 

Once an active manager is assigned to the user again, the login will be successful (via API Client or UI).

Keywords

Authentication failed, LGN0019, ODATA API, invalid manager ID , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

Product

SAP SuccessFactors HXM Suite all versions