SAP Knowledge Base Article - Public

2901335 - Error Message when Opening the Ticket Data Source

Symptom

When previewing the standard data source Ticket (technical ID CRMSRQHB) you will receive the error message "Report cannot be opened; report an incident" or "Report cannot be opened. (KBA:1926357)"

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Business Analytics.
  2. Go to the view Design Data Sources.
  3. Search for the data source Ticket (ID CRMSRQHB) and preview it.
  4. Run the data source.
  5. You will receive the error message "Report cannot be opened; report an incident" or "Report cannot be opened. (KBA:1926357)"

Cause

This data source has too many fields, and as the preview is nothing but a simulation of the report execution, by default all the fields from the data source will be added to the report. When there are too many fields, a stack overflow error will be raised in the backend.

Resolution

Please create a new report with only the relevant fields, then the reports should work fine. It is also recommended to use variables in the report selection to reduce the data volume that is loaded in the report.

Keywords

CRMSRQHB, preview, data source, Report cannot be opened; report an incident, error, dump, ticket, preview , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions