Symptom
When using Custom Workflow Notifications with Document Generation you notice double line spaces in the Email Notifications that are being received.
You have already confirmed you have not copied & pasted from Microsoft Word and a Border is not in use by the template.
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Environment
Employee Central - Document Generation
Reproducing the Issue
- Create a new Workflow Document Template
- Add your Temple Content using only single line spaces
- Save Document Template and complete reamining configuration for using Custom Workflow Notifications with Document Generation
- Trigger Workflow and check Email Notification
- Note double line spacing in the notification received
Cause
This is expected as by default Document Generation Templates space each line by using paragraph tags - <p></p>
Resolution
To change this behaviour you need to manually alter the source of the template content.
- With the exception of the first open paragraph tag (<p>) and the last close paragraph tag (</p>) - remove all other paragraph tags.
- At the end of each sentance where you want to add a single line space, add a close line break tag: </br>
Note: You do not use the open line break tag (<br>) only the close line break tag.
Keywords
Double, Space, Line, Spacing, Email, Notification, Document, Generation, Custom, Template, Workflow, , KBA , LOD-SF-EC-DOC , Document Generation , LOD-SF-EC , Employee Central , Problem