SAP Knowledge Base Article - Public

2902485 - No Response from Avalara in Sales Document After Avalara Integration and Activation

Symptom

You activated the Avalara standard integration and configured the Communication System and Communication Arrangement.

When creating a Sales Document such as a Sales Order the Tax Code is not determined and you get no response from Avalara.

Environment

SAP Business ByDesign

Reproducing the Issue

Cause

You are using the new REST API.

Avalara has provided two APIs for tax determination.

Business ByDesign uses the old REST API https://developer.avalara.com/api-reference/avatax/rest/v1/methods/getTax/.

The usage of new REST API https://developer.avalara.com/api-reference/avatax/rest/v2/methods/Transactions/CreateTransaction/ is not supported as of now.

Resolution

You need to identify a mechanism of using the legacy API https://developer.avalara.com/api-reference/avatax/rest/v1/methods/getTax/ with Avalara.

See Also

Please also see the Blog: Avalara Configuration in SAP Business ByDesign

Please Note: 
The blog reffers to the setup in test or development systems and therefore uses the hostname "development.avalara.net" since this should be used for test and development systems.
For productive systems please use the hostname "avatax.avalara.net".

Keywords

Avalara; No response; Tax Code; Not determined , KBA , AP-TTE-TC , Tax Calculation , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions