Symptom
When you try to Confirm Execution on a Contract containing Services, you notice that the generated Service Confirmation does not automatically fetch the Service Items from the Contract.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Contracts view.
- Open Customer Contract ABC (ABC Represents the ID of a Contract including Service Items).
- Click the Submit Button and then Complete Execution.
The system will open a New Service Confirmation screen, and scrolling down you can see that the Items section is empty.
Cause
Service Contract items are not automatically copied over to the subsequent Service Confirmation. This differs from the Sales Order and Service Order scenarios where the items are automatically copied.
Resolution
For the cases where the Service Confirmation is created from a Contract, you will need to manually add the items.
Keywords
Service Contract, Copy, Fetch, Bring over, Items, Service Confirmation , KBA , AP-CCP-CC , Customer Contract , How To