Symptom
You want to understand how the Completion Date is determined in a ticket.
Environment
SAP Service Cloud
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Search and open ticket ID AAA (AAA represents the ticket ID).
- Go to the Overview facet to the Timeline pane.
- Check the Completion Date.
Cause
The Completion Date is determined based on the ticket status.
Resolution
The Completion Date is set whenever the Ticket is changed from a Status mapped with the Assignment Status "Processor Action" to a status mapped with Assignment Status "Requester Action".
Example:
- Agents sends a reply to the customer and sets status to "Waiting for Customer" - mapped to Requester Action.
- Completion Date is set accordingly.
- Customer comes back and status is set back to "In Process" - mapped to Processor Action.
- Agent responds to customer and sets status to "Completed" - mapped to Requester Action.
- Completion Date is set to the new date.
Note that changing the status from a Requester Action status to another Requester Action status does not re-determine the Completion Date. The date is only maintained again when changing status to a Requester Action assignment status.
Keywords
Completion Date; Ticket; Completed; Requester Action; Processor Action; , KBA , completion date , ticket , requestor action , completed , LOD-CRM-SRP , Service Request Processing , How To