SAP Knowledge Base Article - Public

2903640 - Workflow Rule for Activities

Symptom

You have created 2 workflow rules in the system:

  1. First workflow rule to create an Activity
  2. Second workflow rule to send an e-mail once the Activity is created

But the second workflow rule does not send the e-mail once the activity is created via first workflow rule.

Environment

SAP Cloud for Customer.

Cause

This scenario is not supported.

Any workflow rule defined on Activity will not execute when the activity is created via workflow at the time of creation to avoid scenarios like recursion where it might end up in loop and will keep on creating/updating the activities again and again.

Resolution

This is the standard behavior of the system as of now.

Though once the activity is created via workflow, any update done on the activity either via workflow or manually will trigger the workflow rule as usual.

Keywords

KBA , activities , e-mail , task , workflow , LOD-CRM-WKF , Workflow , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions