Symptom
You are trying to cancel a Contract item to avoid invoicing, but you cannot as the Contract Item Start Date is in the future.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Contracts view.
- Search for the Contract ABC (ABC represents the ID of the Contract).
- Click Edit.
- Navigate to the Items tab.
- Select the Line Item XX (XX represents the Line Item ID)
- Enter the Cancellation information.
- Click Save.
Item XX remains In Process.
Cause
A Contract item will only be canceled once it reaches a date within the Contract Item Start Date and Contract Item End Date.
For example, if the Contract Item Start Date is set as 02.01.2021 and Contract Item End Date is set as 01.01.2022, the system will only be able to cancel the item within these dates, not before it.
Resolution
This is the expected system behavior.
In order to avoid having the system generating the invoice, please perform the following
- Go to the Contract ABC.
- Click Edit.
- Navigate to the Pricing and Invoicing tab.
- Select the Invoicing subtab.
- Select an option under Invoicing Block.
- Click Save.
The Invoice Request document will remain blocked and once the system reaches the cancellation date within the Contract Item Start Date and Contract Item End Date, it will be canceled.
See Also
2153275 - Not able to Cancel a Contract Line Item with the Same Date as the Start Date
2865417 - Error When Trying To Cancel Contract: "Item XX: Effective cancellation date must be between contract start and end dates"
Keywords
Contract, Item, Invoicing, Cancel, Invoice Request , KBA , AP-CCP-CC , Customer Contract , How To