Symptom
You receive the error "ChangeSet index 1 - oldJobInfo or time is null" when you attempt to approve a Return to Work workflow.
Environment
Employee Central - Time-Off
Reproducing the Issue
- Navigate to the profile of a user on a Leave of Absence
- Enter the Actual Return Date for this user to trigger the workflow
- Proxy as the approver of the workflow and attempt to approve the workflow
- Receive the error: ChangeSet index 1 - oldJobInfo or time is null
Cause
This is caused by the user currently being active in the system. This could be because of a Job Info change or a Termination/Rehire.
Resolution
Ensure that the data for this user is correct. If they are currently active in the system, this will need to be corrected. This could be done manually or through Full Purge or Incremental import.
Keywords
leave of absence, error, return to work, ChangeSet index 1 - oldJobInfo or time is null , KBA , LOD-SF-EC-TIM , Time Off , Problem