Symptom
You have created an Extension Field and added it to the Account screen, but it does not work on the Basic Search.
Environment
SAP Cloud for Customer
Reproducing the Issue
- For this article purpose, let's use as example a field "ZLast Contacted" (ZLast Contacted represents the Extension Field name).
- Go to the Customers work center.
- Select the Accounts view.
- On the Account list, see that the field ZLast Contacted is populated for Account ID XYZ (XYZ represents the Account ID). It shows date DD.MM.YY (this represents a Data).
- On the Basic Search, type in DD.MM.YY.
- No records found.
Cause
Extension Fields of datatype = 'Time', 'Date', or 'DateTime' are not enabled for Basic Search.
Resolution
This feature is not supported in the current release of SAP Cloud for Customer.
An alternative option may be to check the SAP Cloud for Customer Ideas Forum to submit an idea: SAP Cloud For Customer Influence
Keywords
Extension field ; search ; ticket ; opportunity ; lead ; not working ; search ; field ; date , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions