Symptom
You have created an Extension Field and added it to the Account screen, but it does not work on the Basic Search.
Environment
SAP Cloud for Customer
Reproducing the Issue
- For this article purpose, let's use as example a field "ZLast Contacted" (ZLast Contacted represents the Extension Field name).
- Go to the Customers work center.
- Select the Accounts view.
- On the Account list, see that the field ZLast Contacted is populated for Account ID XYZ (XYZ represents the Account ID). It shows date DD.MM.YY (this represents a Data).
- On the Basic Search, type in DD.MM.YY.
- No records found.
Cause
Extension Fields of datatype = 'Time', 'Date', or 'DateTime' are not enabled for Basic Search.
Resolution
If you have the need to use such fields in basic search urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center . You can contact Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of SAP Application Development site , choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea.
Keywords
Extension field ; search ; ticket ; opportunity ; lead ; not working ; search ; field ; date , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , How To