Symptom
We are facing an issue whereby when running the snapshot creation it is displaying message "Created 0 time account snapshots."
The users do have a balance for the Time account and also have a Pay Group Maintained in Job information
Environment
Employee Central
Reproducing the Issue
Create Snapshot and Run
Cause
The Pay group field is not enabled and/or field is enabled but not maintained in Compensation Information of the employee.
Time Account Snapshot feature is based on time account and compensation information. For the given time account type in which Snapshot Allowed setting is set to 'Yes', snapshot calendar will get all time accounts that are open and bookable on balanceEffectiveDate (Time Account Snapshot Calendar End date) then for all the time accounts found in this step, system only then selects the employees for whom the snapshot will be generated. For the selected employee group, system filters the employees using the compensation information and then reads the pay group of an employee where the pay group is the same as the pay group defined in the snapshot calendar.
Based on the above logic, if pay group field is not enabled and/or if field is enabled but not maintained in Compensation Information of the employee, snapshot generation would not work
Resolution
Enable and maintain the Pay Group Field in Compensation Information.
Keywords
Snapshot creation, Created 0 time account snapshots, Pay group, snapshot, snapshot creation is empty, snapshot report has no results , KBA , LOD-SF-EC-TIM , Time Off , Problem