SAP Knowledge Base Article - Public

2906013 - External Id Field is Missing in Contract OWL Screen In Adaptation

Symptom

You are unable to find the External ID field in adaptation mode within the Contract OWL.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Contracts work center.
  2. Go to the Contract view.
  3. Click Adapt.
  4. The 'External Id' field is not available to be added in OWL screen.

Cause

The scoping question: "Do you want to replicate contracts between your cloud solution and external application?" is not scoped.

Resolution

Please follow the below steps to enable the external ID field:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the relevant Project.
  4. Click 'Edit Project scope'.
  5. Go to step 4, 'Questions'.
  6. Expand the Communication and Information Exchange -> Integration with External Applications and Solutions -> Select the 'Integration into Sales, Service, and Marketing Process'.
  7. Flag the 'In Scope' check box for the question: "Do you want to replicate contracts between your cloud solution and external application?".
  8. Click Next and Finish.

After performing the above steps, the External ID field will be available in the Contract OWL screen.

Keywords

External ID, Contract , KBA , contract , external id , missing , owl , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions