Symptom
- Users close the browser and when they open it again, they are still logged into their account
- All users are SSO-enabled
- The SSO they're using is SP-initiated
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Enter the SuccessFactors instance via SSO
- Once inside the instance, close out the browser
- Open the browser again > account is still logged in
Cause
This is an expected behavior for SP-initiated SSO logins.
SP-initiated SSO stores the credentials and account in the browser cache and cookies, which is why the users will always be logged into their accounts within the browser
Resolution
There are two options to explain this behavior:
- Manual Logout Process: There is no forced logout, unless the user logs out manually.
- Clearing Browser Cache and Cookies: User can also clear browser cache and cookies to delete the session.
IMPORTANT: Basic Authentication and third-party direct integration with SAP SuccessFactors HCM suite will reach end of maintenance and support on June 2, 2025, and be deleted on November 1, 2026. We are requesting for all systems to be migrated to the Identity Authentication service by this time.
- Check more details about it in Help Guide Deprecation of Basic Authentication and Third-Party Corporate Identity Provider (IdP) Direct Integration with SAP SuccessFactors HCM suite.
- Blog Link: Deprecation of Basic Auth/3rd Corporate Identity P... - SAP Community
See Also
- KBA 2396658 - [SSO] SP Initiated Logout
- KBA 2396644 - SSO- How does IDP & SP Initiated Logout work
- KBA 2791410 - Integrating SuccessFactors with Identity Authentication IAS through the Upgrade Center
- KBA 3472405 - Deprecation of Basic Authentication and Third-Party Corporate Identity Provider (IdP) Direct Integration with SAP SuccessFactors HCM suite
Keywords
browser, sso, logout, sp initiated, url, link, session, close, clear, cache, cookies, save, single sign on , KBA , LOD-SF-PLT-SAM , SAML SSO First Time Setup , Problem