SAP Knowledge Base Article - Public

2907920 - Incoming B2C E-mail Generates Error Instead of Creating a New Customer in C4C

Symptom

When an e-mail is sent to C4C B2C E-mail Channel, the system does not create a new customer and generates one of the following errors in Web Service Message Monitoring:

  • Agent has selected more than one error message as fatal;
  • Customer Save Failed. E-Mail processing aborted;
  • Incoming e-mail has incorrectly formatted sender address;

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Administrator work center.
  2. Navigate to Web Service Message Monitoring.
  3. See the errors for the E-mail interface being generated

Cause

The error messages are displayed since the e-mail processing is failing for the e-mails.

This can be caused by invalid sender names or addresses, for example, when the sender has a special character in their user account name.

If the e-mail addresses are formatted correctly, this can indicate an issue with the customer e-mail configuration on their mail service provider or a PDI implementation affecting the Customer/Ticket creation in the system.

Resolution

The user name and email address of the sender cannot have special characters or symbols.

Apart from this, the company must review the configuration in their mail service provider is correctly maintained and confirm if any PDI implementation is impacting the Customer creation. In case everything is verified, reproducible scenarios need to be shared to the SAP Support team for further checks.

Keywords

Agent has selected more than one error message as fatal; Customer Save Failed. E-Mail processing aborted; Incoming e-mail has incorrectly formatted sender address; E-mail; B2C; C4C; Channel; Error; Web Service Message Monitoring; Inbound; Customer; Service; special character; symbol , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions