SAP Knowledge Base Article - Public

2910066 - Field Type is Greyed While Creating a New Task in Activity Plan

Symptom

The field Type is not available for adding while creating a new task in an activity plan.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activity Planner work center.
  2. Go to the Plans view.
  3. Select plan ABC (ABC represents the id of the plan).
  4. Go to the Tasks facet.
  5. Select New.
  6. Enter Adaptation Mode.
  7. Select the section to add new fields.

RESULT: In this section group items, there is a field called Type, however, this is not available for adding.

Cause

The value here is set by default and is not editable by manual changes.The field type here refers to the type code which is set by default for a task or survey and in this case it is set for a task, since this screen is meant for task creation.

Resolution

This is the system expected behavior. The system does not allow you to make changes to this field.

If you need this functionality urgently you may contact your implementation manager.

Keywords

Activity Plan, Task, Type, Type Code, Survey , KBA , task , survey , type code , adaptation , field , grayed , greyed , document type , LOD-CRM-ACT-ROT , Activity Routing , LOD-LE-SUR-EXE , Survey execution = runtime , LOD-LE-SUR-DEF , Survey definition = design time , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions