Symptom
After requesting a Q to P transport you go to Manage Your Solution app, and receive the following message:
A technical error has occurred during activation. SAP is working on the same and will re-start the system once the error has been resolved.
Sometimes, this error can be caused due wrong entries for configuration step 101118 - Set Pricing Procedure Determination.
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Environment
SAP S/4HANA Cloud.
Cause
This is due to the fact that wrong configuration exists in configuration step 101118 and it can cause some locks (in transport and activation).
Let's say you have a custom pricing procedure Z17002 and ZPR0 condition type is assigned in Configuration Step 101117 - Set Pricing Procedures:
When you check configuration step 101118 - Set Pricing Procedure Determination, you can see condition type PPR0 is assigned instead of ZPR0:
So, Condition Type PPR0 is not in Pricing Procedure Z17002.
Resolution
To avoid this locks or even errors, you should check and correct the wrong entries for configuration step 101118 - Set Pricing Procedure Determination.
Keywords
pricing procedure, condition type, custom pricing procedure, custom condition type, customizing, transport issue, procedure determination, PPR0, ZPR0, transport, Q to P, Set Pricing Procedure Determination, 101118 , KBA , SD-BF-PR , Pricing , SV-CLD-FRM-APP , Flexorg, Foreign Key Check , SV-CLD-FRM-INF , Implementation Framework Infrastructure , Problem