Symptom
After requesting a Q to P transport, the following message is received in the "Manage Your Solution" app:
A technical error has occurred during activation. SAP is working on the same and will re-start the system once the error has been resolved.
Sometimes, this error can be caused due to wrong entries for configuration step 101118 - Set Pricing Procedure Determination.
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Environment
SAP S/4HANA Cloud.
Cause
This is due to the fact that wrong configuration exists in configuration step 101118 and it can cause some locks (both in transport and activation).
For instance, if there's a custom pricing procedure Z17002 and ZPR0 condition type is assigned in Configuration Step 101117 - Set Pricing Procedures:
It might happen that in the configuration step 101118 - Set Pricing Procedure Determination, the condition type assigned is PPR0 instead of ZPR0:
So, Condition Type PPR0 is not in Pricing Procedure Z17002.
Resolution
To avoid these locks or possible errors, the wrong entries for configuration step 101118 - Set Pricing Procedure Determination should be checked and corrected.
Keywords
Pricing procedure, condition type, custom pricing procedure, custom condition type, customizing, transport issue, procedure determination, PPR0, ZPR0, transport, Q to P, Set Pricing Procedure Determination, 101118. , KBA , SD-BF-PR , Pricing , SD-BF-PR-2CL , Pricing (Public Cloud) , SV-CLD-FRM-APP , Flexorg, Foreign Key Check , SV-CLD-FRM-INF , Implementation Framework Infrastructure , Problem