Symptom
- Should we change our Company ID if we have People Analytics enabled?
- Impact of changing SF Company ID
- Report - Story not working after changing SF Company ID.
Environment
- SAP SuccessFactors HXM Cloud
- SuccessFactors People Analytics
Reproducing the Issue
- Organisation changes SF Company ID.
- Log into BizX via IAS.
- Navigate to Reporting
- Run any pre-existing Report - Story.
- Report does not work as expected.
Cause
- It is only supported to change the CompanyID/Instance ID name for newly created instance which have no existing configuration or integrations existing within the instance.
- If you carry out a change of Company ID/Instance ID, this may corrupt your existing report - story.
Resolution
in order to mitigate any issue, please take a backup of your existing reports using the export option in Report Centre & re-import the Report - Story collection afterwards.
Keywords
Report - Story, People Analytics, Embedded Edition of People Analytics, SAC, Rename company ID, instance ID change , KBA , LOD-SF-ANA-SAC , Stories in People Analytics , LOD-SF-PLT , Platform Foundational Capabilities , Problem
Product
SAP SuccessFactors HCM Suite all versions