SAP Knowledge Base Article - Public

2910318 - Error: 'Not a valid logon token. FWB00003', when saving a report from Crystal Reports to SAP BusinessObjects Enterprise

Symptom

  • Error when trying to save reports.
  • Unable to save reports from Crystal Reports to the server.
  • When trying to save a report from Crystal Reports to the SAP BusinessObjects Enterprise repository, it fails with the error:
    "Not a valid logon token. FWB00003"

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
            
  • SAP BusinessObjects Business Intelligence Platform 4.1
  • SAP BusinessObjects Business Intelligence Platform 4.2

Reproducing the Issue

  1. In Crystal Reports, open a report, or create a report of any data source.
  2. Under the menu "File", select "Save"
  3. In the "Save" window, select "Enterprise" in the left pane, and enter the SAP BusinessObjects Business Intelligence platform information and user credentials.   
  4. Enter a name for the report, and save it.
        
    It then generates the error: "Not a valid logon token. FWB00003"

Cause

  • The error occur when the version of Crystal Reports does not match the version of the SAP BusinessObjects Business Intelligence Platform it attempts to save the report to.
            
    For example: If you are using:
        - Crystal Reports 2016 with Support Pack 02
        - SAP BusinessObjects Business Intelligence Platform 4.2 with Support Pack 08
       
    When attempting to save a report from Crystal Reports to the SAP BusinessObjects Business Intelligence platform, it will fail because the product are not at the same Support Pack version. One is using Support Pack 02, and the other one is using Support Pack 08

Resolution

  • Update the Support Pack of Crystal Reports, to match the Support Pack installed on the SAP BusinessObjects Business Intelligence Platform.
       
    For examples:
      
    If you are using:   
    - Crystal Reports 2016 with Support Pack 02
    - SAP BusinessObjects Business Intelligence Platform 4.2 with Support Pack 08
       
    Then the solution is:
    - To update Crystal Reports 2016 to Support Pack 08, to match the version of the SAP BusinessObjects BI 4.2 Server.
      
       
    If you are using:
    - Crystal Reports 2016 with Support Pack 04
    - SAP BusinessObjects Business Intelligence Platform 4.2 with Support Pack 03
         
    Then the solution are:
    - To update SAP BusinessObjects Business Intelligence Platform 4.2 to Support Pack 04,
       to match the version of Crystal Reports 2016 used; OR  
       
    - To uninstall Crystal Reports 2016 - Support Pack 04, and install Crystal Reports 2016 with Support Pack 03,
       so the SAP BusinessObjects BI server and Crystal Reports are at the same Support Pack level.

Keywords

CR, product Mismatch, lower version, higher version, CRDesigner, login, SAP BI server, repository , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016