Symptom
While creating new recurring invoice you see an error when you give current date in recurring invoice as start date.
or
When ever the next creation date is current date and the job run date is also current date and time in UTC, that is not yet happened then you will see this error.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier invoicing work center
- Go to recurring invoices view
- Select an Active document
- Under General tab
- Red mark appears against the field Creation date of next invoice
Cause
Cause 1.While creating a Recurring Run you will see below.
The Job run has already occurred on current day in UTC & the next creation date of invoice is current day so the system knows that the supplier invoice cannot create on current day.Thus you will see the error.
or
Cause 2. On a Recurring Run created earlier you will see the below always
The Job run is yet to occur on current date and time in UTC & the next creation date of invoice is current day so the system considers that the supplier invoice did not create on current day till the Job run is occurred on the current day. Thus till the Job run occurs you will see the error always.
Resolution
Resolution 1:( to avoid Cause 1 )
Mention next day date or above, in the start date field of the recurring run and also reschedule the job run with Job run date as next day and time as 00:30(time zone same as your personalize settings).
or
Resolution 2.( to avoid Cause 1 )
If you want to give today's date in the start date field of the recurring run then first reschedule the job run with run date as current date and time as current time+X mins(where X is expected to be minimun 5 mins(within this time you can create new recurring run or change the existing recurring run))(time zone same as your personalize settings).
Resolution 3.( to avoid Cause 1 and Cause 2)
You will still see the error if you follow Resolution 2, as explained in the cause 2.
So we request you to create manual recurring invoice for current date and then follow Resolution 1.
How to reschedule the Job run?
- Go to application user management
- Go to background jobs view
- Select"Recurring invoicing for all buyers" click on Reschedule button
- Enter date as next day and time as 00:30 in UTC ( convert time 00:30 in UTC to your time zone same as your personalize settings and enter the time).
See Also
For more details refer the details in the KBA:2648081 - Recurring Invoices are not Getting Created
Keywords
Red mark appears against the field Creation date of next invoice; recurring invoices not created though creation date is given correctly;Creation Date of Next Invoice is Before Current Date (Incident has been created automatically);The creation date of the next invoice is earlier than the current date , KBA , creation date of next invoice , SRD-SRM-SI , Supplier Invoicing , Problem