Symptom
- An External Candidate was able to create a Candidate Profile using an Internal Candidate's email address.
- Internal Candidate created a Candidate Profile through the External Career Site using their Internal Profile's Email Address.
Environment
SAP SuccessFactors Recruiting Management
Cause
The option "Use email as external applicant user ID" is ticked in Provisioning, so the primaryEmail field contained the userSysId for the internal candidate, and the external candidate contained the email address they used, which is one of the fields the system takes to do a validation if the candidate is duplicated.
Resolution
To explain that, some background is required to fully understand what is happening.
In Recruiting Management, there are two email fields: contactEmail and primaryEmail. The field contactEmail is supposed to configure which email the candidate will be contacted or receive notifications from the system. The field primaryEmail is supposed to be related to the user's username or what they would use to log into the career site.
There is a checkbox in Provisioning that is called "Use email as external applicant user ID". So, when you have that ticked the candidate's username will also be the candidate's email. But that only happens for External Candidates or when an internal candidate is converted into an external candidate.
For internal candidates, this field primaryEmail will be populated with the user's User Sys Id, which is what the system considers to see if the candidate is internal or external. When the field primaryEmail is filled with the User Sys Id, it will be considered internal. If it's filled with an email address, it could be considered an external candidate.
That means that when the external candidate created their profile, they have filled the email field with their email address, while the internal candidate has the primaryEmail field with their User Sys Id value, so that's why the system allowed the external candidate to create the candidate profile. Otherwise, it'd throw an error message.
If both of the candidate profiles belong to the same person and that is something that your business process would allow to be done, a workaround for this case to avoid having two candidate profiles for the same user would be to merge both Candidate Profiles so it will become one.
See Also
2666892 - Use email as external applicant userId - Recruiting Management
2676324 - The primaryEmail Field Within the Candidate Profile - Recruiting Management
Keywords
internal candidate, external candidate, candidate profile, internal candidate created an external candidate profile, same email, email address used in two candidate profiles, contactEmail, primaryEmail. , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-CAP , Candidate Profiles , Problem