SAP Knowledge Base Article - Public

2911145 - Business Partner Removal Run Does not Pick up Obsolete Business Partners

Symptom

The Administer Obsolete Business Partner Removal Run completes without deleting any business partners, even though relevant (e.g. obsolete)  records exist.
When checking the logs of the relevant deletion run, the results show a message similar to 'No private account found as per selection criteria'; 'No Contacts found as per selection criteria'.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Business Partners
  2. Select Business Partners view 
  3. Show All and find the business partner to be deleted
  4. Find the following status: Obsolete
  1. Go to the work center Data Protection and Privacy
  2. Select Common Tasks
  3. Select Administer Obsolete Business Partner Removal Runs
  4. Select the log of the relevant run
  5. A message indicates that no relevant business partner is found as per selection criteria.*

*The message depends on the type of  business partner. Examples:

  • No Private Accounts found as per selection criteria
  • No Contacts found as per selection criteria

Cause

Possible causes include

  • For accounts: The retention period, as maintained in the data retention rule in the business configuration, has not yet expired.
  • For contacts, the retention period of a customer offer associated with the contact has not expired.
  • In the Obsolete Business Partners delete run, 'Only business partners marked as End of Purpose' is selected as 'Yes' even though such business partners don't exist.
  • The problem may be caused by an application error. Note: To find the application error for a business partner that was not considered in the Manage Obsolete Business Partner Removal run, search for the business partner in the application log result. Even after the error is corrected, the affected business partners are not included in the automatic business partner deletion run.

Resolution

To avoid such problems:

  • Where applicable, ensure that retention periods are taken into account. These are maintained in the Business Configuration activity. They can be maintained for different countries and are valid accordingly. Deletion is only possible after the retention period has expired. Note: For contacts, see KBA 2793614 - Frequently Asked Questions on Data Protection and Privacy Work Center.
  • Ensure that employees are no longer valid/terminated so that they are included in the run.
  • Ensure that customers and contacts are set to obsolete so that they are included in the run.
  • For contacts, ensure that the retention period of the associated customer quotes has expired.
  • If you want to delete business partners that are not marked as End of Purpose, remove the 'Yes' option from 'Only business partners marked as End of Purpose' in the run configuration, and then schedule the delete run.

To resolve such issues:

  • Records without application errors can be processed and resolved on the customer side. Such errors should appear in the 'Personal Data Removal' in the Data Protection area and can be manually removed there.
  • Records with correctly marked application errors must be processed and resolved on the customer side. This means that the reason for the application error must be resolved first. After that, the affected business partners can also be removed manually in the Personal Data Removal view in Data Protection and Privacy Owl (they will not be picked up again by the automated business partner deletion run).
  • If the removal of personal data is not possible, open an SAP support case from the relevant system with reference to this KBA. Describe the steps to reproduce and specify the relevant records. Inform us of the required actions and obtain authorization to perform them.
  • Records with incorrectly marked application errors must be corrected by support. Please open a case from the relevant system with reference to this KBA, specifying the records and why the application is not working. Provide the permission to solve the issue.

See Also

KBA: 2793614 - Frequently Asked Questions on Data Protection and Privacy Work Center

KBA: 2538645 - The Data Retention Period of Countries is not Populated as Per the Current Legislation in Your Business Configuration Implementation Project

Keywords

not working, consider, recognise, missing, deletion , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions