SAP Knowledge Base Article - Public

2911400 - How To Cancel Sales Order With a Service Line Item

Symptom

You have a Sales Order with a Service Line Item. You want to know, on how to cancel it. For cancelling a Sales Order with a Material Line Item, see 1755905.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to the Sales Orders work-center.
  2. Go to the Sales Orders view.
  3. Search for DEF. (DEF represents the Sales Order ID)
  4. DEF has a Service Line Item and the delivery status is finished.

Try to cancel the Sales Order and it will not be possible.

Cause

The Reason for Rejection field on the sales order line depends on the Delivery Status. See below table.

Once the Reason for Rejection is maintained, the remaining quantity will be cancelled, you are not able to create new service confirmation or invoice.

Sales Order Item Delivery Status Cancellation
Service Line  Not Started The Reason for Rejection is editable and cancellation can be done on the Sales Order screen.
Service Line  In Process The Reason for Rejection is editable and cancellation can be done on the Sales Order screen.
Service Line  Completed Depending on the Service Item Type, the Invoice, Service Confirmation or both will have to be cancelled firstly. 

Resolution

In order to cancel the Sales Order line, please follow the below:

  • Line Item Type, Service: Time & Material and Service: Fixed Price
  1. When the Status is In Process or Not Started, the Reason for Rejection will be enabled. Hence, the Sales Order line can be cancelled.
  2. When the status is Completed, first the Invoice has to be cancelled. Then, the Service Confirmation will have to be cancelled by maintaining a Reason for Rejection. This will set back the delivery status on the sales order line back to In Process.
  3. The Sales Order line can now be cancelled, by maintaining a Reason for Rejection.
  • Line Item Type, Service: Fixed Price without Actuals
  1. When the Status is In Process or Not Started, the Reason for Rejection will be enabled. Hence, the Sales Order can be cancelled.
  2. When the status is Completed, the Invoice has be cancelled firstly.
  3. The Sales Order can now be cancelled, by maintaining a Reason for Rejection.

See Also

1755905 - You are not able to Cancel a Sales Order

2644606 - How to maintain the Reason for Rejection in Project Based Sales Order Item 

2632981 - How to Cancel an A2A Service Order in ByDeisgn System

1913197 - How To Cancel Sales Order Created Via Intercompany Process

2580915 - Error When Cancelling Sales Order Item - The action CANCEL is Not Possible 

Keywords

"Cancel", "Service", "Sales Order", "Service Confirmation", "Time & Material", "Fixed Price", "Fixed Price without Actuals" , KBA , AP-SLO , Sales Order Processing , Problem

Product

SAP Business ByDesign all versions