SAP Knowledge Base Article - Public

2911737 - Error in Business Process Tile - No process variant set by the rule as the conditions did not match.

Symptom

When onboarding is initiated for the candidate, the candidate did not land in the Onboarding Dashboard. Instead, the following error occurred in Business Process tile: 

"No process variant set by the rule as the conditions did not match. Please update the rule conditions"

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate Onboarding from Recruiting
  2. Click on the To-Do
  3. Select Business Process
  4. Select the error associated with the candidate

Cause

The conditions within the business rule with the scenario "Select Process Variant" is not successfully evaluated for the initiated candidate

(or)

The custom process variant associated in the business rule is inactive.

Resolution

  • Evaluate that all the relevant field values configured in the "Select Process Variant" rule is successfully passed for the impacted user
  • This data can be validated from the Suite Integration Tool (if the candidate is initiated from RCM)

(or)

  • Go to Process Variant Manage > Select the Custom Process Variant
  • Activate the Process Variant and Save it successfully
  • Post this, update the BPE Service User from "Update Onboarding and Offboarding Process Flow"

See Also

Keywords

Process variant manager, Business Process Tile, new Hire, PVM, BPE Error, BPE, No process variant set by the rule as the conditions did not match, Rule, Select Process Variant, Onboarding , KBA , LOD-SF-OBX-PVM , Customized onboarding process flow , LOD-SF-OBX-BPE , BPE Process Flow , Problem

Product

SAP SuccessFactors Onboarding all versions