Symptom
Once the Candidate it Initiated from RCM, Error is occurred in Business Process tile.
""No process variant set by the rule as the conditions did not match. Please update the rule conditions""
Environment
Successfactors Onboarding 2.0
Reproducing the Issue
Initiate ONB from RCM
Go to Home Page and check for Business Process Tile and check the error
Cause
Using Custom process with wrong configuration in Business Rule
Resolution
Follow the below steps to fix this issue.
1) Make the you have selected and added the Custom Process in Process Variant Manager and also set it as Active.
2) Go to Admin Center-> Manage Process Definitions, click on the filter icon. On the Process Definition Filter dialog box, enter the ID of the process variant that you just created in the Process Definition Key Like field, and click Apply.
make sure your Custom Process is appearing here.
3) Go to Configure Business Rule and Open the Rule for Scenario Process Variant. Check below in Rule.
A) Rule scenario is selected as Process Variant
B) Check the Date and Tile Format Selected Correctly.
C) Check the Condition and make sure your Custom Process ID is appearing in the Condition.
D) Make the business rule is Set as Always True
Keywords
Process variant manager, Business Process Tile, new Hire , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem