SAP Knowledge Base Article - Public

2911823 - Email/Offer Letter token resolving as a number instead of the label

Symptom

  • You are using a token on an email or offer letter template
  • The value on the recruiting form (Job Requisition, Application, Candidate Profile, or Offer Detail) is showing correctly as text
  • However, the token is resolving as a number, instead of the text
  • The field is a picklist field type

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. On an email template, add a token which references a picklist field.
  2. Ensure that a text value is showing on the recruiting form.
  3. Generate the email, and notice that a number is showing, not the text of the field.

Cause

The picklist value being used for that field has been deleted.

The number being shown for the token is the option ID of the picklist value which has been deleted.

When a picklist value is deleted, it will continue to show the text on the recruiting form until updated, but in reports and tokens only the option ID will be shown.

To confirm this, find the picklist associated to this field in Picklist Management or Picklist Center. Then check the value associated with the option ID which is showing for the token, and see if the value is no longer active.

Resolution

To resolve the issue, you can either:

  1. Make the picklist value active again.
  2. Open the recruiting form, and select a new active picklist value.

See Also

KBA 2787587 - "My picklist is showing the numeric Option ID instead of the values in Ad Hoc reports - Recruiting Management"

Keywords

optionId, code, approval, wrong value, object, centre, obsolete, inactive , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions