Symptom
You activate a user for Outlook Server Side Integration, however, upon opening the Outlook Add-in and clicking on "Create New", you see objects which are not assigned to the particular profile that is assigned to the Organization that this user belongs to.
Environment
SAP Cloud for Customer
Reproducing the Issue
Cause
If user has the same access rights as a key user, they will be provisioned automatically as a key user when they open the E-Mail Integration settings for the first time. During this auto-provision they will be assigned to Default Organization and the Default Profile. This is key user provisioning logic and it can't be changed.
Regular users are provisioned in a different way. During provisioning, they may be assigned to another Organization and Profile.
Resolution
This is the standard provisioning behaviour.
See Also
Keywords
Server Side Outlook provisioning, Key User, Default Profile, profile assignment, incorrect , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To