Symptom
When trying to add an agency user, an error shows up and the user is not added: "Email for the external recruiter already exists!".
Environment
SAP SuccessFactors Recruiting Management
Cause
The user is already added to another agency.
Resolution
When the user is already added to another Agency in the system, the system will prevent you from adding this user to another agency.
A way to overcome this is to doublecheck which agency you would like to maintain the user, and change the user's email address of existing Agency in order to have it added to the new one. For example, if you have the user in Agency A, but would like to add them to Agency B, you will need to edit the user's email in Agency A to something else in order to be able to add the user to the Agency B.
Keywords
agency user, add new user to agency, Email for the external recruiter already exists, unable to add new agency user, cannot add agency user. , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-POR , Career and Agency Portals , Problem