Symptom
As part of the Story report upgrade and enablement process (either self triggered via Upgrade Center or SAP triggered), SAP integrates SuccessFactors, IAS/IPS, and SAP Analytics Cloud tenants, applying standard configurations. However, if these standard settings in IAS/IPS have been changed, it may lead to incorrect configurations, and as a consequence some users might face difficulties accessing Story reports.
- Scenario 1: A blank or continuously loading screen (three-dots)
- Scenario 2: An error indicating your profile is not correctly configured “Your profile is not correctly configured for Story reports. This can be a user sync issue. Please contact your system administrator for further assistance.”
- Scenario 3: A message suggesting third-party cookies must be enabled in the browser
This KBA lists all possible causes and links to the documents where the standard configuration is explained.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
After successfully upgrading to Story reports in SuccessFactors and completing all implementation steps (such as user synchronization and permission assignment),
- Navigate to Report Center
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Click New
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Select Story
You may encounter either a blank or continuously loading screen, or an error message may be displayed.
Cause
Here are the most frequent configuration issues that lead to such symptoms:
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Browser settings blocking third-party cookies
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The Identity Authentication or Identity Provisioning Service (IAS/IPS) settings for SuccessFactors are not aligned with the standard configuration established during the enablement process
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User synchronization problems (missing Person GUID, IPS misconfigurations)
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Reverse Proxy or Forced Authentication enabled
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Inconsistent SAML configuration between systems
Resolution
Start by using the Check Tool to verify all IAS settings: 3336576 - Check Tool to verify IAS settings for Stories - SAP for Me
After confirming that all checks have passed, proceed to create a Story and attempt to replicate the issue you encountered. Based on the outcome, follow the Scenario:
Scenario 1A blank or continuously loading screen |
Scenario 2An error indicating your profile is not correctly configured |
Scenario 3A message suggesting third-party cookies must be enabled in the browser |
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This issue may arise due to several possible configuration mismatches. Please review the following scenarios for potential causes:
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This suggests that the affected user's profile has not been successfully synchronized with the SAC server. User accounts are synced to both IAS and SAC during the IPS sync process. If this synchronization fails for any reason, the account will not appear in the SAC tenant.
To troubleshoot, start by using the Check Tool to confirm whether the user is present in SAC server: 299447
If the user is not present, you would have to Sync the user to SAC server following this Help doc |
This indicates that third-party cookies are currently disabled in the browser. You can find the necessary steps to enable them for Microsoft Edge and Google Chrome in the following KBA: 3039244
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Note:
- Story Reports are not compatible with Reverse Proxy configurations. To ensure proper functionality, Reverse Proxy must be disabled.
- Support Access is not available for partners logging in via Provisioning using secondary logon, as this method bypasses Identity Authentication (IAS). Partners should access Story Reports using their own login credentials. Full Support Access is only available to SAP’s internal support team, through a secure, authorized channel.
Assuming all primary configurations are correctly set, there may still be corner cases related to IAS settings that must remain in their default state to ensure proper behavior:
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Attributes in SAC should continue to be inherited
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Default NameID format in SAC must be set to Unspecified
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Apply function to Subject Name Identifier in SAC should be configured as None
Making changes to these default settings could lead to unexpected integration issues, so it's recommended to leave them unchanged.
If the issue continues after verifying the configurations mentioned above, please raise a ticket with the Support Team and include the following information:
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SuccessFactors Company ID
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Support User ID & Username of the affected individual
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IAS & IPS URLs (Once an Engineer is assigned, ensure that admin access is granted to the assigned Support Engineer)
See Also
SAP SuccessFactors Stories: Enablement Configurations
Default transformation for SCIM IPS Connector (Permission based user sync):
- SF Source - https://d.dam.sap.com/a/ELSSVfC/SAP%20SuccessFactors%20Source-SCIM%20with%20Group%20Domain.pdf?inline=true&rc=10&doi=SAP1031160
- SAC Target - https://d.dam.sap.com/a/r1FQNZf/SAP%20Analytics%20Cloud%20Target-SCIM%20with%20Group%20Domain.pdf?inline=true&rc=10&doi=SAP1031156
2954815 - Configuring IAS and IPS when two SuccessFactors instances are mapped to one IAS tenant
Keywords
stories, story reports, Blank loading screen, unable to access, three dots, loading, profile not configured, user not created in SAC, user missing in SAC, create story stuck, third-party cookies, third party cookies, enabled, browser settings , KBA , LOD-SF-ANA-SAC , Stories in People Analytics , LOD-SF-ANA-SAC-ADM , SF Admin configurations (Security Center, Provisioning) , LOD-SF-ANA-SAC-IPS , IPS configurations and Sync Job , LOD-SF-ANA-SAC-IAS , IAS configurations , How To
Product
Attachments
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SAP Knowledge Base Article - Public