SAP Knowledge Base Article - Public

2913038 - Mail Blocked In Ticket Interactions

Symptom

You observe that an incoming e-mail was blocked with the message "The mail was blocked due policy violation containing unsupported html tags" in Ticket Interactions.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service work Center.
  2. Go to Tickets view.
  3. Open the Ticket XYZ (Where XYZ indicates the Ticket ID).
  4. Go to Interactions tab.
  5. You can see that an incoming e-mail was blocked.

Cause

The cause of this message "The mail was blocked due policy violation containing unsupported HTML tags" is that the inbound e-mail contains unsupported HTML tags. The HTML Tags that are not supported are: Iframe, Form, Input, Script, Object, Embed, Bgsound.

This was enforced with our migration to new inbound mail infrastructure. Please check the rejected mails and verify if they contain the not allowed tags.

With the old infrastructure, HTML tag <iframe> triggers a special classification - dangerous.iframe - which is set to "reject" whereas the new infrastructure covers additional tags, indicated above.

Resolution

We would strongly recommend to review the tags that are excluded from a security perspective. In case you want those tags to be excluded from our rejection mechanism, kindly let us know so that we can ask our hosting team to exclude it at a tenant level.

NOTE: Mails with HTML tags <iframe> will still be bounced as it is considered dangerous and not supported.

Keywords

mail, blocked, html, tag, policy, violation, inbound, email, incoming, ticket, interaction , KBA , mail , tag , html , reject , blocked , bounce , violation , policy , incoming , ticket , html tags , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer add-ins 2020