Symptom
When configuring alerts to trigger after an employee's termination the e-mails are not sent
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Configure an alert to trigger after an employee is terminated
- Terminate the employee
- Run the job EC Alerts and Notifications
- The alert is created
- When the Alert's effective date is reached no e-mail is sent
Cause
Once the employee is inactive the system no longer recognizes the user and is not able to send the e-mail based in this subject.
Resolution
This is expected behavior of the system since the subject employee is terminated. Currently there is no workaround for this behavior.
In case you have a business requirement for this you can open an enhancement request following the KBA 2090228.
Keywords
terminated employee, not receiving e-mail, does not trigger alert , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem