SAP Knowledge Base Article - Public

2913990 - Service Order ID not Shown in Customer Invoice Item Data Source

Symptom

The Service Order IDs are shown as # when you search the Customer Invoice Item data source by Customer Contract IDs and only Service Confirmation IDs are shown.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Business Analytics Work center.
  2. Navigate to Data Sources view.
  3. Open Customer Invoice Item (data source ID: CRMCIVIB) data source.
  4. In the selection, under customer contract choose the Contract ID XYZ(XYZ is the ID of the Contract which has Service Order and Service Confirmation as follow up documents for contract)
  5. Add the Contract field, Service Order field and Service Confirmation field to the rows and selection screen
  6. Click on Apply
  7. You can see the data source displays only the service confirmation IDs. The service order are all displayed as "#".

Since the Contract XYZ has the follow up documents Service Order and Service Confirmation, you expect both to be available in the data source.

Cause

The Contract XYZ has the Item with Item Type as Time and Material and it is invoiced with reference to Service Confirmation and not Service Order. The Customer Invoice Item data source shows the referenced documents with respect to which the item is invoiced.

Resolution

The Customer invoice item data source shows the service confirmation for the contract because it is the reference document for invoice and not the service order. This is system standard behavior

Keywords

Customer Invoice Item; Customer Invoice Item data source; Service Order; , KBA , customer invoice item service order , customer invoice item data source , AP-SVO , Service Order Processing , Problem

Product

SAP Business ByDesign 1911 ; SAP Business ByDesign 2002