SAP Knowledge Base Article - Public

2915567 - Workflow Rule to send email to Approver Involved Party does not work

Symptom

A Workflow Rule which is to send emails to the Approver Involved Party of a Sales Quote does not trigger.

Environment

SAP Sales Cloud

Reproducing the Issue

Prerequisite: a Workflow Rule set up to send emails to the Approver of a Sales Quote; also a valid Approval Process for Sales Quotes.

  1. Go to the Sales workcenter.
  2. Go to the Sales Quotes view.
  3. Open any Sales Quote and Submit for Approval.

Result: the Approver is listed in the Approver facet but the Workflow Rule is not triggered

Cause

The Approver Involved Party in the Workflow Rule is not the same as the Approver from the Approval Process.

Resolution

In order for this WFR setting to work, the Approver needs to be added to Involved Parties for Sales Quote via PDI or using the Rules in Administrator -> Sales and Campaign Settings.

Alternatively, there is also an option to subscribe to Notifications.

See Also

KBA 2780886 - No “Subscribe to Email” icon in Notification

Keywords

workflow rule, approver, involved party, email, notification , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions