SAP Knowledge Base Article - Public

2917258 - Field SalesOrganisationID is not available in the Odata Activity Collection

Symptom

You want to filter the Activities based on the Sales Organization. But,the related field is not available in the Odata Activity Collection.

Environment

SAP Cloud for Customer

Reproducing the Issue

  • Go to Odata Service Explorer.
  • Select the Service c4codataapi and Test.
  • Select the Activity Collection and execute the below URL: https://myXXXXXX.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/ActivityCollection.
  • The field SalesOrganisationID will not be visible.

Cause

The field SalesOrganisationID is not part of the Standard Odata Activity Collection.

Resolution

You need to create the Custom Odata Service inorder to include the SalesOrganisationID field.

  • While creating Custom Odata Service, Select the Business Object as Activity.
  • Select the Root Node and then expand it.
  • In the Root Node, you can find the field SalesOrganisationID.
  • Select the SalesOrganisationID and other relevant fields.
  • Save and activate the Odata Service.

Keywords

Activity, Odata, SalesOrganisation , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Problem

Product

SAP Cloud for Customer add-ins all versions