Symptom
Error: "Claim Date" does not match with your system date. Please contact your admin. when editing existing benefit employee claim
Environment
- SuccessFactors Employee Central
- Global Benefits
Reproducing the Issue
- Go to Manage data
- Benefit employee claim > Search for a employee claim record that has claim date in past
- Edit > Make corrections
- Make any changes to the record
- Click save > Error
Cause
Disable client date validation is set to 'No' in Benefit
Resolution
- Go to Manage Data > Benefit > Search for the benefit id for which you want to change the claim
- Take action > Make correction
- Search for 'Disable client date validation' > change this to 'Yes' > save changes
- Now change benefit employee claim record and no error appears.
Why we need to Disable client date validation?
- We are checking in the system if client and server date difference is not more than 24 hours.
- When employee tries to claim he/she can change the system date and try doing claims for a past date or a future date though the period is closed. To avoid that we are checking this validation.
- For admins to make such changes, we provided the field “Disable client date validation” so that they can disable this validation and proceed with any past dated or future dated changes in Manage data.
See Also
Keywords
benefit employee claim, claim start date, edit benefit employee claim, Claim Date does not match with your system date. Please contact your admin, Claim date does not match with system date , KBA , LOD-SF-EC-GBF , Global Benefits , Problem
Product
SAP SuccessFactors Employee Central 2005 ; SAP SuccessFactors HXM Core all versions