SAP Knowledge Base Article - Public

2917643 - Donut Charts Results Are Not Updated When Filtering Results For A List Field

Symptom

When filtering the results in an OWL for a list field, the data in the donut chart does not reflect the filtered results.

Environment

SAP Cloud for Customer

Reproducing the Issue

This scenario can apply to different views, in this example we use Accounts.

  1. Go to the Customers work center.
  2. Open the Accounts OWL.
  3. Click the 'Show Donut Chart' button in the toolbar.
  4. Note the results shown in the Donut Chart are not aligned with filtered results in the OWL.

Cause

The data shown in the Donut Chart is determined by the current selected query. All data from this query will be shown in the charts.

Resolution

This is current Expected Behavior.

Should your business require this behavior to be changed, please post this new feature request on our influencer page: click your user icon at the top of the screen and choose 'Share Your Ideas' or go directly to: https://influence.sap.com/SAPCloudforCustomer.

Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.

See Also

You Are Not Able to Customise/Edit The Donut Charts

Keywords

Opportunities, Leads, Sales Quotes, Tickets, results , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer add-ins 1905 ; SAP Cloud for Customer add-ins 1908 ; SAP Cloud for Customer add-ins 1911 ; SAP Cloud for Customer add-ins 2020 ; SAP Cloud for Customer core applications 1811 ; SAP Cloud for Customer core applications 1902 ; SAP Cloud for Customer core applications 1905 ; SAP Cloud for Customer core applications 1908 ; SAP Cloud for Customer core applications 1911 ; SAP Cloud for Customer core applications 2002 ; SAP Cloud for Customer core applications 2005 ; SAP Cloud for Customer core applications 2008