Symptom
You activated the standard Service Portal Integration. You are having the required access assigned to your OData Technical User. Upon creating the Ticket from the Service Portal, you receive the error:
Unauthorized: The service 'c4codata' is not assigned to you.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login to the Service Portal with the OData Technical User credentials
- Create a Service Request Ticket
- System throws the mentioned error
Cause
The c4codata service is deprecated and cannot be used via Technical User. You have configured the Service Portal project with the c4codata APIs which is deprecated.
Resolution
Services that are added to Communication Arrangement can only be accessed via Communication Arrangement's Technical User. In this case, use c4codataapi instead of c4codata service. For $metadata calls there is no authorization restriction with Technical User.
Adapt the Service Portal project with the new OData APIs instead of the deprecated one. Any enhancement that needs to be done has to be performed at your side.
See Also
The following links give information about new OData APIs :
Keywords
Service Portal, Technical User, OData, OData Technical User, c4codata, c4codataapi, Service Portal Integration, Communication Arrangement , KBA , c4codata , c4codataapi , portal integration , service portal integration , odata , technical user , odata technical user , LOD-CRM-INT-API , OData API (C4C Only) , Problem