Symptom
Data Source Sales Order Item is missing a specific account and the corresponding sales orders when logged in as user XX(XX is the ID of the user who is facing the issue)
Environment
SAP Business Bydesign
Reproducing the Issue
- Login with the User ID XX((XXX is the ID of the user who is facing the issue).
- Go to Business Analytics work center.
- Go to Data Sources View .
- Search for Data Source Sales Order Item.
- Preview the data source.
- Filter the report by Employee Responsible = XX(XX is also the Employee Responsible in the Sales Orders which are missing in the Report).
- In the report results, the account YY and the corresponding Sales Order ZZ are missing(YY is the account ID and ZZ is the Sales Order ID which the user is unable to find in the report).
Cause
The user has restricted access for the work center sales order based on sales unit XYZ(XYZ is the ID for Sales Unit) which means, the user XX can only see the sales orders which is having the sales unit XYZ.
The user is unable to see the Sales Order ZZ in the report because, the sales order ZZ does not have the Sales Unit XYZ.
Resolution
This is standard system behavior. If you want the user to see the sales orders then you will have to enhance the access restrictions for the user XX
- Go to Application and User Management work center
- Go to Business Users
- Search for user XX and edit Access restrictions
- Go to tab Access Restrictions and search for Work center view ID CRM_SALESORDERS
- Select the line CRM_SALESORDERS, under detailed restrictions you can see to which all sales unit , this particular user is having access.
- Provide access to other sales units by clicking on the checkbox to resolve the issue.
Keywords
Sales Order Item; Data Source; Sales Order missing; , KBA , sales order item data source , AP-SLO-SO-ANA , Analytics , Problem