SAP Knowledge Base Article - Public

2917997 - Issue when Uploading a Custom Solution into a Tenant

Symptom

When attempting to upload a custom solution into a tenant using the Cloud Applications Studio, the below erros are faced:

  • Wrong developer key or content was modified. Report an incident.
  • SP CL_PDI_RI_XREP_SP_ABAP1 failed to process file /ABCDEF123_/……/XYZ.absli in solution $STAGING branch $DEFAULT  (ABCDEF123_ represents the custom solution ID and XYZ represents the ABSL file name).

Environment

  • SAP Business ByDesign.
  • SAP Cloud for Customer.
  • SAP Cloud Applications Studio.

Cause

This issue occurs when the patch is activated and assembled by a PDI development user which has a non-English language defined and causes ABSL files to be incorrectly generated.

Resolution

Please do the following in the source development system where the solution was assembled:

  1. Change the logon language of the affected PDI Development user from Non-English language to English.
    • Go to the Administrator or Application and User Management Work Center.
    • Enter the Business Users View.
    • Find and Edit the Attributes of the affected business user.
    • Change the language to English.
  1. Create a new patch version.
  2. Right-click in the affected script file from the error message and select option "Clean Up".
  3. Re-activate the ABSL script file.
  4. Assemble and download the new patch.

Before proceeding to upload the new patch version to the target tenant, ensure that your user is defined with the English language on both tenants.

Keywords

Deploy, Deployment, PDI, SDK, Fail, Error, Import, System , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , AP-RC-BDS-1O , ByDesign Studio OneOffs , AP-RC-BDS-SCR , ByDesign Studio Scripting (ABSL) , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions