Symptom
We see variations in SF LMS permissions for the same admin user in the new LMS interface when compared to the Flash interface.
Admins have access to Role Management, Administrators, Security Domain Groups even though they do not have the required permissions. In the old UI they do not have access.
Environment
SAP SuccessFactors LMS
Cause
Workflows that grant access to entity menus have been made more straightforward in the new administrator navigation.
Currently, access to each entity menu is granted to an administrator based on that entity’s ‘Search’ or either the ‘Edit ‘or ‘View’ workflows.
In the new Learning Administrator navigation, the ‘Search’ or ‘Add’ workflows will grant access to a menu.
For instance, to access the Library (Catalog) menu, either the Search Library (Catalog) or Add Library (Catalog) workflows will grant access to the Library (Catalog) menu within the Learning Activities main menu.
Administrator ‘View’ or ‘Edit’ Library (Catalog) workflows will grant further access.
Resolution
If the admin doesn't require access to the search functionality, remove the search permission in question.
Keywords
KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , How To