SAP Knowledge Base Article - Public

2918254 - The Following Process Communication Error Occurs in a Sales Order: Postal Code Region Mismatch

Symptom

The following Process Communication Error occurs in a Sales Order: Postal Code Region Mismatch

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open Sales Order XYZ (XYZ represents the ID of the Sales Order).
  4. Navigate to the Document Flow
  5. You can see that there is a process communication error.
  6. Click on the red exclamation mark. 
  7. You can see the following error description:
  8. - Sales Order XYZ cannot process an update sent by a Customer Invoice
  9. Once your service provider has solved the errors, the system closes the errors and restarts the processes automatically".
  1. Go to the Application and User Management work center. 
  2. Select the Process Communication Errors view.
  3. Select the following option from the drop-down list: Open Errors with Incident.
  4. Set the Filter in Receiving Document ID as XYZ.
  5. Select Receiving Document Sales Order XYZ.
  6. You can see the following process communication error:
    Postal Code Region Mismatch
    Saving not possible due to status of document

Cause

You configured an external tax provider.

There can be 2 causes of this error:

  • The State/RegionCode of the Address in the Sales Order is not maintained.
  • The Postal Code/Zip Code and the State/Region Code maintained in the Address does not match. 

Once you configure an external tax provided, you have to make sure that all the addresses within the system are correct, especially the postal and region codes (e.g State and Zip Code/Postal Code) should be in sync because the external tax provider validates all the addresses being sent to it.

Resolution

To solve the issue you need:

  • Correct the Addresses in your Account Master Data and ensure that for all Addresses the State/Region Code and Postal Code/Zip Code are maintained and correct.
  • Cancel the Sales Order XYZ and all follow up documents. Then create a new Sales Order (not a copy of Sales Order XYZ) with the correct data and complete the process.
  • Once the Sales Order XYZ and all follow up documents were canceled create an Incident with reference to this issue and all details such as Sales Order ID and performed changes send the Incident to SAP.

We can cancel the process communication message.

See Also

This is also mentioned in the Blog: Vertex Configuration in SAP Business ByDesign

Keywords

Postal Region Code Mismatch; Zip Code; State; Vertex; Avalara; External Tax Provider;Mismatch; Region Code , KBA , SRD-CRM-ORD , Orders & Contracts , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions